Forum issues

For creating groups, suggesting features, reporting problems and the like.
User avatar
M0rtimer
Global Moderator
Posts: 11173

Forum issues

Post by M0rtimer » Thu Feb 25, 2016 1:30 am

It appears the forum is undergoing some maintenance? Opening most topics results in the following error:

Fatal error: Call to undefined method bbcode::spoil_pass() in /var/www/web341/html/domains/goblins/goblinsforum.com/www/includes/bbcode.php(112) : regexp code on line 1

Sounds like someone did something to break the spoiler tag..?

User avatar
Theis2
Moderates Controversy!
Posts: 6340

Re: Forum issues

Post by Theis2 » Thu Feb 25, 2016 1:57 am

You suck!
Games I'm in
► Show Spoiler
I'm a GM for Shipwrecked
And the Shipwrecked OOC thread

User avatar
M0rtimer
Global Moderator
Posts: 11173

Re: Forum issues

Post by M0rtimer » Thu Feb 25, 2016 2:10 am

Yeah, it's been confirmed that using the spoiler tag is the issue... Any page that has a spoiler on them will refuse to load.

On that note, let's crash this topic too!

Han solo shot first.

User avatar
Theis2
Moderates Controversy!
Posts: 6340

Re: Forum issues

Post by Theis2 » Thu Feb 25, 2016 2:14 am

Trying to use url= ] makes the forum puke all over you just by attempting to post it..

*edit
Trying to post any bbc codes makes it cry..
Games I'm in
► Show Spoiler
I'm a GM for Shipwrecked
And the Shipwrecked OOC thread

User avatar
M0rtimer
Global Moderator
Posts: 11173

Re: Forum issues

Post by M0rtimer » Thu Feb 25, 2016 3:09 am

Yeah, seems most codes are broken...

nikohl
Discussion Moderator
Posts: 4575
Location: Ó▓á_Ó▓á

Re: Forum issues

Post by nikohl » Thu Feb 25, 2016 3:40 am

Glad it's not just me having these issues! I am browsing from my phone because my PC's PSU decided to die yesterday, and I thought my phone might just be being grumpy... But I guess it's the forum.

User avatar
Krulle
Transcribes Goblins
Posts: 6853
Location: banned
Contact:

Re: Forum issues

Post by Krulle » Thu Feb 25, 2016 6:39 am

Also <tabs> is broken
I did PM this thread to SeeAMoose, in the hope he didn't switch off e-mail notification.

edit to add: well, since quite a few use spoil and url tags in their signatures, and the loading does still work (although the bbcode tags are not converted to html tags), and Theis2' profile page does work, and SeeAMoose's profile page does not work, it seems to me that <tabs> is more problematic right now.

User avatar
thinkslogically
Game Master
Posts: 12687
Location: Glasgow, UK

Re: Forum issues

Post by thinkslogically » Thu Feb 25, 2016 8:04 am

If Duke Igthorn's still an admin, I'm pretty sure he's on twitter if any of you guys can send him a message that way? It might be worth trying a few different non-forum contact avenues just in case the message to Moose doesn't get through.

(Edit to add: I'm not being lazy by not doing it myself, it's just I use my twitter account for work so I'd prefer not to start flagging forum games issues with it :) )

User avatar
GathersIngredients
Discussion Moderator
Posts: 4695

Re: Forum issues

Post by GathersIngredients » Thu Feb 25, 2016 9:39 am

I don't have a twitter account.
Still getting used to the new forum, also waiting to post until it is "done".
Krulle wrote:My bad memory allows me to enjoy positive news far more often!
Excited for the Isle of Starlight!
Hunters of Letrua: Loki "Boarstrangler" - Obsidian portal page
► Show Spoiler

admin
Site Admin
Posts: 16

Re: Forum issues

Post by admin » Thu Feb 25, 2016 12:48 pm

Oh well poop. It seems an update to the forum software killed a lot of the custom tags.
Thing is, I was about to announce a bigger update this week anyways, which would possibly break a few things but is needed for security reasons. (Since we're still on phpBB 3.0.x and the update to 3.1 kinda breaks all mods.

I do have a backup from last night, so if all fails I can just reinstate that (albeit at the loss of whatever happened here today).

In any case the bigger update is nigh, so it's good if you guys gather infos on what breaks so we can try to work over each lost modification. :)

Most "sad" effect will be that the fantasy theme we have will become unusable alltogether, and we need to look out for a new one to use. ;_;

I'm @Duke_Igthorn on Twitter or @TheDukeInPurple on Telegram if anyone needs to contact me. ;)

Thanks for the heads up! <3

Cheers,
Dukey~

User avatar
Krulle
Transcribes Goblins
Posts: 6853
Location: banned
Contact:

Re: Forum issues

Post by Krulle » Thu Feb 25, 2016 1:06 pm

Just found time and wanted to prod @Duke_Igthorn, but Mortimer alrady did:

https://twitter.com/Duke_Igthorn/status ... 6918897666

Cannot use quote, so you have to use the link....
Apparently Duke rolled out some emergency update yesterday which broke the tags, he is already looking for,a solution...
:)

heh, didn't notice post did not work, as Admin ninja'ed me.... ;)
posting now...

User avatar
M0rtimer
Global Moderator
Posts: 11173

Re: Forum issues

Post by M0rtimer » Thu Feb 25, 2016 1:21 pm

Seems topics are operable again! The afflicted tags don't work anymore being plain text now, but that's better than a crash. :P Good work Duke. :)

So when do you think we'll be making the switch to 3.1? Anything we should be aware off with that on our end?

admin
Site Admin
Posts: 16

Re: Forum issues

Post by admin » Thu Feb 25, 2016 1:23 pm

Okay I reinstalled the mods we had and you guys need to test now if things broke spectactularly or just in a minor way. XD

This will only be a temporary fix since as soon as the big update comes we'll have to pretty much redo all mods and theme related things with what is available for the new phpBB versions.
That sure will be "fun" ;P

Cheers,
Dukey

User avatar
GathersIngredients
Discussion Moderator
Posts: 4695

Re: Forum issues

Post by GathersIngredients » Thu Feb 25, 2016 1:31 pm

Thank you kindly. :thumbsup:
Still getting used to the new forum, also waiting to post until it is "done".
Krulle wrote:My bad memory allows me to enjoy positive news far more often!
Excited for the Isle of Starlight!
Hunters of Letrua: Loki "Boarstrangler" - Obsidian portal page
► Show Spoiler

admin
Site Admin
Posts: 16

Re: Forum issues

Post by admin » Thu Feb 25, 2016 1:36 pm

M0rtimer wrote:Seems topics are operable again! The afflicted tags don't work anymore being plain text now, but that's better than a crash. :P Good work Duke. :)

So when do you think we'll be making the switch to 3.1? Anything we should be aware off with that on our end?
Well I want to do the update as soon as possible but since it will bring major changes, we'll have to look together for ways to reinstate all the special things we had that standard phpBB didn't have. (aka what we used mods for)
It might also break some posts permanently (or until someone bothers to fix them manually). Not "never to be readable again" broken, but "tags are weird code now" broken.
It might be possible to re-use the tag system in another mod so they work again, but we'll see that when it happens.

Also we have to look for a new theme sadly. It might be possible to sorta edit the one we have to make it compatible but from what I read so far we might at best be able to reuse its assets to form a new one.
We'll see ^^ At least no one will drop dead from seeing a default theme for a while. ;)

User avatar
Krulle
Transcribes Goblins
Posts: 6853
Location: banned
Contact:

Re: Forum issues

Post by Krulle » Thu Feb 25, 2016 2:41 pm

admin wrote:Okay I reinstalled the mods we had and you guys need to test now if things broke spectactularly or just in a minor way.
Minor: tag <align> is not working (see my signature). You can just as well wait for the completed update before adressing this. tag <tab=50> [tag=50] not working. (see gathers' signature inside spoiler)

edit: align does work in post preview, but not in my signature. possibly dues to overlap with other phpBB tags (in my sig <url=> tags)

User avatar
RocketScientist
Global Moderator
Posts: 5187
Location: Massachusetts

Re: Forum issues

Post by RocketScientist » Thu Feb 25, 2016 5:18 pm

Wow, I just went over to the phpBB site to look at their themes. What a confusing mess. Is there no way to sort them by "will work with the newest version" or what? :? Weird.
Image Image Image

User avatar
thinkslogically
Game Master
Posts: 12687
Location: Glasgow, UK

Re: Forum issues

Post by thinkslogically » Thu Feb 25, 2016 6:17 pm

I guess you can filter them (I dunno, I found a link). Here's the 3.1 styles :

https://www.phpbb.com/customise/db/styles-2/3.1

There are much nicer styles available if we're willing to pay for them. I guess we as forum members could donate to any costs (which I don't think are very high). Anyway, just a thought - I know less than nothing about this stuff!

User avatar
RocketScientist
Global Moderator
Posts: 5187
Location: Massachusetts

Re: Forum issues

Post by RocketScientist » Thu Feb 25, 2016 8:50 pm

I did not even see that was an option. :oops: Thanks. That will teach me to pay attention. I'd be willing to chip in for a decent theme. We spend enough time looking at it. lol.

BTW, are we aware that the main comic site is down?
Image Image Image

User avatar
SeeAMoose
Admin Moose on the Loose
Admin Moose on the Loose
Posts: 1293
UStream Username: See_a_Moose
Location: Maryland (DC Area)

Re: Forum issues

Post by SeeAMoose » Thu Feb 25, 2016 10:27 pm

Glad you all were able to get a hold of Duke, I just got home a little while ago. I did get the pm's but you can also email me directly if I'm needed at adminmoose@goblinsforum.com or botwalter@gmail.com. I get those pretty quickly. (Lately though I'm a bit swamped).
I am one of the forum admins and chat moderators. Drop any of us a line if you ever need a hand in either the forum or the chat.
You can reach me at AdminMoose@goblinsforum.com or at BotWalter@gmail.com

User avatar
RocketScientist
Global Moderator
Posts: 5187
Location: Massachusetts

Re: Forum issues

Post by RocketScientist » Thu Feb 25, 2016 10:36 pm

OK.

Also, Happy Birthday, Moose. Image
Image Image Image

User avatar
Synch
Game Master
Posts: 4470
Location: New Zealand

Re: Forum issues

Post by Synch » Fri Feb 26, 2016 3:30 am

I like this one:

https://www.phpbb.com/customise/db/styl ... 83dbc8812f

But thats just a personal preference of mine, as I often use Microsoft Visual Studio at work and I prefer the black background to white. Easier on the eyes for me.
► Show Spoiler

User avatar
Krulle
Transcribes Goblins
Posts: 6853
Location: banned
Contact:

Re: Forum issues

Post by Krulle » Fri Feb 26, 2016 4:03 am

I also prefer dark backgrounds, but I got so used to the standard phpBB front, as I encounter it on several forums, that I won't mind either way.

nikohl
Discussion Moderator
Posts: 4575
Location: Ó▓á_Ó▓á

Re: Forum issues

Post by nikohl » Fri Feb 26, 2016 4:26 am

I use (and will probably continue to use) Prosilver.

User avatar
RocketScientist
Global Moderator
Posts: 5187
Location: Massachusetts

Re: Forum issues

Post by RocketScientist » Fri Feb 26, 2016 9:27 am

Ugh. I can't stand dark backgrounds. They give me a headache.
Image Image Image

Post Reply